Blood to perfection on XP

Discussion about using or improving the BuildXP guide.

Moderator: Moderators

Post Reply

Blood to perfection on XP

Post by Sidious » Wed Dec 20, 2006 5:24 pm

Finally i have been able to tweak blood to perfection, both in single player and multiplayer. I have also managed to make it run over the internet through GIT. Anyone interested in all of the settings and maybe "Blood it out", let me know.


Post by ddraig » Sun Dec 24, 2006 3:58 am

Yes please. I still cant get blood to run above 640x480.
I've tried voodo wrappers the works. The GIT stuff is interesting too.


Post by Guest » Sun Dec 24, 2006 11:32 am

1.install blood
2. install vdmsound 2.10
3. install VDMSound LaunchPad Shell Extension v1.0.1.1
4. go here:
download this patch:
r0011.exe - Updates Blood (Registered) from 1.00 to 1.11.(install it)
5. get the soundblaster fix patch: it)
6. get nolfb.exe, place it in the blood folder
7. get cli2nop, run it. (type "cli2nop -p blood.exe")
8. download a VMDSound shortcut for blood here: (if it doesn't start the download procedure, right click on this link and chose "save link as")
once downloaded, create duplicates of this blood.vlp file and rename them to setup.vlp and commit.vlp. You must of course edit the files created and make them point to their respective .exe files in the blood folder.

9. Blood to perfection:
open up your VMDSound folder, find the VDMS.ini file and open it.
scrolling down the file you will find a section called:
[DMA Transfer Manager.config]
by default the minDMAPeriod is set to "5". change it to "1". save and close.
now you need to download a patch for a windows file:
install it, and chose "y" to reboot.
Sound configuration:
enter Blood's setup by clicking on the setup.VLP file. These are the correct music/sound settings:
Sound FX Card: SoundBlaster
-Address: 220
-Type: Sound Blaster 16 or AWE32
-Interrupt: 7
-8 bit DMA: 1
-16 bit DMA: 5
Music Card: General MIDI
-Midi port: 330

Screen setup:
chose "VESA modes" and 800x600

9.Edit your blood.vlp/commit.vlp file:
right click on the .vlp file, select "properties".
in the "VDMSound" tab, there is a square containing the MIDI emulation.
by default, this is set to "other". change it to "General MIDI (GM) or GS"
now, click on the "advanced" button and find the "Performance" tab.
here you will find a square containing the "DMA servicing". by default the minimum "Polling period" is set to 5. change this to 1. now settings in the .vlp file will be coherent with the settings you did in the VDMS.ini file and you will no longer get the "unhandled exception" error when starting blood from your .vlp files.
game will be smooth, and the sound is perfect

get commit.exe version 1.4
commit.vlp: right click on it, and select the "advanced" button. find the "compability" tab. at the bottom, enable "low level network support".
install nwlink ipx/spx transport protocol
to do this:
start->control panel->network connections
right click on the connection u are using. click on "install". chose the right protocol.
to be able to play a multiplayer game in blood, all players must reside in the same ipx network, and the specific network number for that network has to be "00000000" (8 zeros).
to do this:
double click on the ipx/spx protol you just installed.
set internal network number to "00000000" - 8 zeros.
just to be sure everything is ok, go to start->run. type "cmd", which opens the command prompt. type "ipxroute config".
correct settings shows:
IpxLoopbackAdapter 1234cdef
theNameOfYourConnection 00000000
allTheOtherConnections 00000000

last of the last things:
to play multiplayer, you can only have ONE connection activated in "network connections", which is the connection containing the network card that's been given the ip-address from your dhcp-server. If you have more than 1 network card installed on your system, you need to deactivate that connection, or else upon launching commit, blood will search the network and find that network adapter and say: "found 2 players". blood thinks that it's a player, which it of course isn't.

that's all. Good luck...nah, you dont need it. This works!


Post by Sidious » Sun Dec 24, 2006 11:34 am

That was me! :)


Post by ddraig » Thu Dec 28, 2006 2:19 am

cheers. will check those settings next time I play.

User avatar
Posts: 18
Joined: Mon Nov 20, 2006 4:17 pm
Location: Virginia

Post by DOOMLancelot » Mon Feb 12, 2007 9:50 pm

"Polling period" is set to 5. change this to 1.
That makes the sound a little delayed.
DOOM, Heretic, Hexen, BLOOD, Duke Nukem 3D, Shadow Warrior; they all rock!


Post by Sidious » Mon Feb 12, 2007 10:23 pm

strange, setting the polling period to 1 reduces the digital sound latency and should improve the sound. Have used this recipe on many computers and I have never encountered a sound delay, so I'm not familiar with the problem. how's the sound if you dont change the polling period both in VDMS.ini and the vlp file?

User avatar
Posts: 18
Joined: Mon Nov 20, 2006 4:17 pm
Location: Virginia

Post by DOOMLancelot » Mon Feb 12, 2007 10:43 pm

Sounds just fine without changing that stuff. I guess some things depend on the sound card.
DOOM, Heretic, Hexen, BLOOD, Duke Nukem 3D, Shadow Warrior; they all rock!

Posts: 11
Joined: Fri Feb 15, 2008 1:00 pm

Post by White.Sux » Sun Feb 17, 2008 2:26 pm

hey man this stuff works perceftly for me !

i know its basically based on DEATHMASKS instructions but this worked
the first time i tried it

while using deathmask i needed 3-4 runs to get it working !

and the best is i can choose any resolution up to 1024

second : the sound is crystal clear !
third: no more error when starting up !

thx bud this stuff really helped me !


Post by Guest » Tue May 27, 2008 2:48 pm

I do everything you tell me to, but the game won't run for me with the IRQ set to 7. I have to change it to 5, but then the sound is all crappy.

What can I do?

Caleb 2

Re: Blood to perfection on XP

Post by Caleb 2 » Tue Oct 06, 2009 10:43 pm

I installed the game Blood CD, cli2nop, nolfb, Sound Blaster and not everything worked for me ... I can not play at 800x600 and have problems with IRQ 7 if I try to play is in conflict, but I changed IRQ 5 to test the running game, played without sound. All this only once and then not work anymore.
What I do to works fine and in 800x600


Re: Blood to perfection on XP

Post by NY00123 » Wed Feb 24, 2010 10:35 am

You should now be possible to play Blood online using DOSBox and a multi-player front-end named YANG (Yet Another Netplay guider):
See this thread for more details:
Link to website:

Post Reply